nixos-servers/services/monitoring/pve.nix
Torjus Håkestad 4b38158780
Some checks failed
Run nix flake check / flake-check (push) Failing after 23m15s
Periodic flake update / flake-update (push) Successful in 1m47s
Add pve monitoring
2024-12-03 18:01:48 +01:00

18 lines
369 B
Nix

{ config, ... }:
{
sops.secrets.pve_exporter = {
format = "yaml";
sopsFile = ../../secrets/monitoring01/pve-exporter.yaml;
key = "";
mode = "0444";
};
services.prometheus.exporters.pve = {
enable = true;
configFile = config.sops.secrets.pve_exporter.path;
collectors = {
cluster = false;
replication = false;
};
};
}